Members Login
 

Topic: 97 XJ doesn't latch ASD relay

Post Info
a_q
Guest
Status: Offline
Posts: 1
Date:
97 XJ doesn't latch ASD relay

My '97 UK Spec 4.0 petrol won't start any more.

It cranks over OK but the ASD relay doesn't get held over - which means no spark and no fuel.

When the ignition is switched on the ASD relay clicks over for 2 seconds, then switches off again. I have of course substituted the relay. There are no fault codes.

I have measured all inputs to the PCM and can't see anything wrong:

Here's a list of the reading I took from the PCM multiplug, where there's a difference, "ignition on" is marked with * and cranking with **. Where my wiring colour differs from the '97 manual I have put the colour in (brackets). I have added the circuit function is in [square brackets].

I also checked the ground voltage drop from the battery, because I had read a few posts about bad earths causing problems, it seems quite low, the PCM ground is about 0.17V above the battery -ve post, and the engine is around 0.1V above battery post, both measured during cranking.

PCM Connector
A1 -
A2 (BLU) 12V* 10.8V** [FUSED IGNITION SWITCH OUTPUT (RUN/START)]
A3 -
A4 0V [SENSOR RETURN]
A5 -
A6 - (BLK/YEL) 0V(as I recall) [PARK NEUTRAL SWITCH]
A7 Not tested [IGNITION COILS NO. 1 NO. 6 DRIVER]
A8 0.01V* 0.15V** [CRANKSHAFT POSITION SENSOR SIGNAL]
A9 -
A10 Not tested [AIS MOTOR CLOSE SIGNAL]
A11 Not tested [AIS MOTOR CLOSE SIGNAL]
A12 Not tested
A13 -
A14 -
A15 3.7V [CHARGE AIR TEMP SENSOR]
A16 3.8V [ENGINE COOLANT TEMPERATURE SENSOR]
A17 (Purple) 5.1V - this is the 5V sensor supply
A18 5.1V or 0V* Alternating 5.1V or 0V** [CAMSHAFT POSITION SENSOR SIGNAL]
A19 Not tested [AIS MOTOR OPEN SIGNAL]
A20 Not tested [AIS MOTOR CLOSE SIGNAL]
A21 -
A22 (Red) 12V [FUSED B(+)]
A23 0.87V * Varies with throttle position up to ~3V max [THROTTLE POSITION SENSOR]
A24 4.20V [UPSTREAM HEATED OXYGEN SENSOR]
A25 4.24V [DOWNSTREAM HEATED OXYGEN SENSOR]
A26 -
A27 4.76V* falls to 4.6V ** [MANIFOLD ABSOLUTE PRESSURE SENSOR] (some vacuum then)
A28 -
A29 0
A30 -
A31 0V [GROUND]
A32 0V [GROUND]

"B" Connector not tested yet

C Connector mostly not tested except for

C3 12.1V* 10V** [AUTOMATIC SHUT DOWN RELAY CONTROL] (this should be near 0V to pull the relay over)
C12 0V [AUTOMATIC SHUT DOWN RELAY OUTPUT] (should be 12V if relay is pulled over).

If any more measurements are necessary or useful, please let me know.

 

 



__________________
LIFETIME MEMBER
Status: Offline
Posts: 84
Date:
Do a search on the web for Jeep XJ ASD, or your choice of wording. Seems like the relay and sometimes the wires to it, are common issues. You should get all kinds of hits for the search.

__________________
Steve Martinek
SW Michigan.

2000 XJ Sport 
2005 F350 6.0L Crew Cab
1983 CJ8 - frame off in (slow) progress
1967 Mustang Fastback - future project - waiting for CJ8 to get done

 
Page 1 of 1  sorted by
Quick Reply

Please log in to post quick replies.



Create your own FREE Forum
Report Abuse
Powered by ActiveBoard